easy peasy lemon squeezy


I have been having problems with firefox on my eee for a bit, as I can't get it to update as it seems that firefox 3 is not compatible with Xandros. This wasn't a problem until I kept getting messages when using Google Docs that "your version of firefox is no longer supported in Google... Continue Reading →

Advertisements

Up ↑

%d bloggers like this: